問題

有沒有人嘗試在已經安裝了2005 Developer的機器上安裝SQL Server 2008 Developer?

我不確定我是否應該這樣做,我需要在可預見的未來保持2005在這臺機器上,以便輕鬆測試我們的應用程式.由於我有時需要獲取資料庫的備份檔案併為公司中的其他人提供,我不能只是用2008替換2005,因為我懷疑(但不知道)資料庫不是100%的向後相容.

會出現什麼樣的問題?我是否需要使用例項名安裝新版本,這會起作用嗎?我可以使用不同的埠號來區分它們嗎?

我在technet上找到了這個條目: http://forums.microsoft.com/TechNet/ShowPost.aspx?PostID=3496209&siteid = 17

它不只是說是的,你可以做到這一點,我有點懷疑這是可行的,但我需要知道在我開始安裝之前是否有任何需要知道的東西.

有人嗎?

  最佳答案

是的,這是可能的.您必須根據前一個答案和安裝的.Net版本3.5建立一個不被另一個版本的SQL Server使用的命名例項.工作得很好!

這裡的先決條件列表:

  • .NET Framework 3.5 SP1
  • Windows Installer 4.5
  • Windows PowerShell 1.0

  相同標籤的其他問題

sql-server-2005sql-server-2008installation